Installing Microclimate Developer Tools for Eclipse

Complete the following steps to install Microclimate Developer Tools for Eclipse:

  1. Install and start a local Microclimate instance. Microclimate version 18.12 or later is required.
  2. Download and install the latest Eclipse IDE for Java EE Developers or use an existing installation. The earliest supported version of the Eclipse IDE for Microclimate Developer Tools for Eclipse is 4.8 (Photon).
  3. Install the Microclimate Developer Tools from Eclipse Marketplace.
    • Drag to your running Eclipse workspace. Drag this install button to your running Eclipse workspace. Note: You need to have the Eclipse Marketplace Client.
    • Or, if you want to install from the Eclipse IDE, complete the following steps:
      1. Open the Eclipse IDE and navigate to Help > Eclipse Marketplace.
      2. Search for Microclimate Developer Tools.
      3. Click the Install button.
      4. Finish the wizard and accept licenses as needed.
      5. When the installation is complete, restart Eclipse.